miércoles, 19 de septiembre de 2018

Como instalar e-Sword 11.1 en Linux Ubuntu 16.04




e-Sword es una CompuBiblia, este programa es nativo de Windows pero encontré la manera de poder instalarlo en Linux y que funcione

¿QUÉ FUNCIONA?
Todo, al 100%

APLICABLE A ESTA VERSIÓN:
e-Sword 11.1.0

TUTORIAL APLICABLE A:
Ubuntu y todos sus derivados oficialesLubuntuMythbuntuUbuntu BudgieUbuntu GNOMEUbuntu KylinUbuntu MATEUbuntu StudioXubuntu
- Otros Linux que también usan la administración de paquetes DEB como: Linux MintTrisquelElementary OSZorin OSBodhiDeepin LinuxMX Linux, etc
y debería de funcionar(teóricamente) en:
distribuciones que usan la administración de paquetes RPM como FedoraRed HatOpenSUSECentOSScientific, etc
- Otros Linux basados en Arch Linux como: AntergosManjaroArchBang
- y otras distribuciones independientes de Linux como: GentooMageiaQuirkySolus, etc. Pero allí se usan otros comandos de instalación los cuales usted deberá de buscar.

REQUERIMIENTOS:

1.1.- e-Sword 11.1.0 
Descarguelo desde:

http://www.e-sword.net/downloads.html

o:

descarga alternativa (también para después cuando Rick Meyeres lo actualice y ya no se pueda descargar esta versión desde la pagina oficial):

https://drive.google.com/file/d/1lx8nNyukc8CzbLn5ptFNSFELlupFnI-q/view?usp=sharing


1.2.- e-Sword 11.1.0 Extraido
Este ejecutable yo lo he empaquetado y lo he subido a mi cuenta de Google Drive (es el mismo e-Sword solo que extraido todo su contenido y puesto en una solo carpeta) descarguelo de:

https://drive.google.com/file/d/1JlcH6FfHxh4gbznZFr3r5Ve5QAbaN4kk/view?usp=sharing


1.3.- Modulos
Instale los que yo he recopilado para fines didacticos:

Biblias para e-Sword (WachoPack)
https://facilitarelsoftwarelibre.blogspot.com/2018/02/biblias-para-e-sword-wachopack-2018.html

o

los suyos que usted tenga.

1.4.- Resumen
Es un archivo de texto necesario para seguir los pasos:

https://drive.google.com/file/d/1phIPtRo2pRuWfXX9otJGbE3x0a4i7k_x/view?usp=sharing


2.- Instalar PlayOnLinux
Ponga en una terminal lo siguiente (Comando para Ubuntu, Debian y otros basados en DEB):
sudo apt-get install playonlinux mousepad gnome-exe-thumbnailer
Nota: Con Ubuntu 18.04 y otros nuevos Linux del 2018 debe de usar una versión de wine 3 en adelante, cualquiera de ellas, si no lo hace no funcionará. Así como muestra la sig imagen está bien:



Video de instalación de POL:


3.- Instrucciones de instalación e-Sword en POL


Nota: POL es la abreviación de PlayOnLinux


4.- Lista de verificación
El siguiente video de la lista de pruebas donde confirmo que las opciones de e-Sword funcionan correctamente en Linux:



5.- Cómo instalar modulos .exe de Biblias, Comentarios, Diccionarios, Devocionales en POL
El siguiente vídeo es de cómo instalar los modulos de e-Sword en PlayOnLinux que usted encuentre en la Web:



Otros vídeos para revisar
Estos ultimos dos videos tienen  una versión antigua de e-Sword, lo que pasa es que no es necesario hacer esos videos para cada nueva versión, el procedimiento es lo que importa. Son videos de cómo logré que funcione e-Sword en POL:

Extrayendo e-Sword 10.0.6 con Universal Extractor
https://www.youtube.com/watch?v=F5NeYJDi0oM

Creando el instalador para e-Sword 11.0.6 Extraído.exe - YouTube
https://www.youtube.com/watch?v=UL_zRbr8Aio


Agradezco a Arthur Goicochea Admin de Biblioteca Hispana Int. https://eswordbibliotecahispana.blogspot.com/ (donde también soy miembro) porque me ha motivado a seguirle dando soporte a esta solución para Linux, y así este tutorial también está disponible en https://esword-espanol.blogspot.com.ar/2008/06/como-instalar-e-sword-bajo-linux.html

Dios les bendiga


DESCARGA

6 comentarios:

  1. Estaba con la ilusión de poder usar la nueva versión de e-Sword en Ubuntu desde hace rato y me tenia que conformar con la versió 8.0.6. Seguí estas indicaciones y la verdad que todo marchó bien. Me marcó error al final del proceso y cuando abrí, convencido que volvería a ver la versión anterior, me encontré con la sorpresa que hasta convirtió los modulos a la nueva versión (Instalé 9.7.2). Gracias, gracias.

    ResponderEliminar
  2. Me funcionó perfecto bajo Ubuntu 10.10

    Hice todo lo que dijiste y funcionó de maravilla. Me cambié a Ubuntu pues no quería robar windows y no tenía plata para comprarlo.

    ResponderEliminar
  3. ¡Muchísimas gracias! Ahora puedo usar bien este programa. Bendiciones y gracias otra vez por dedicar tiempo a ayudar a instalar este software.

    ResponderEliminar
  4. ok, seguí los pasos, no sé si en algún punto he fallado pero al intentar iniciar e-sword sencillamente no pasa nada. instalé el wine, winestricks y toda la librería de archivos .dll que suguieres. reinicié la máquina y nada.

    ResponderEliminar
  5. retiro el comentario anterior, revisé paso por paso y había errado en varios procedimientos, a Dios gracias, instalé exitosamente el programa y la librería que mejor me acomoda. gracias!

    ResponderEliminar
  6. Yo la he instalado en mi Ubuntu 10.10, trabaja bien, sin embargo he notado que la herramienta más potente (la búsqueda) no me funciona, ¿alguien ha tenido ese problema? Que la paz de Cristo sea con UDS

    ResponderEliminar

Hola hermano, dejanos tu comentario